Browse Source

Update google-protobuf dependency that works with latest ruby versions

pull/14/head
bumi 1 year ago
parent
commit
21f6466529
  1. 6
      Gemfile.lock
  2. 5
      README.md
  3. 2
      lnrpc.gemspec

6
Gemfile.lock

@ -1,8 +1,8 @@
PATH
remote: .
specs:
lnrpc (0.11.1)
google-protobuf (>= 3.12)
lnrpc (0.13.0)
google-protobuf (>= 3.15.7)
grpc (>= 1.28.0)
GEM
@ -40,4 +40,4 @@ DEPENDENCIES
rspec (~> 3.0)
BUNDLED WITH
2.1.4
2.2.23

5
README.md

@ -5,13 +5,10 @@ a [gRPC](https://grpc.io/) client for [LND, the Lightning Network Daemon](https:
## Installation
Note: there is still an GRPC/protobuf [issue with Ruby 2.7](https://github.com/protocolbuffers/protobuf/issues/7070).
So lnrpc requires Ruby < 2.7.
Add this line to your application's Gemfile:
```ruby
gem 'lnrpc', '~> 0.11.0'
gem 'lnrpc', '~> 0.13.0'
```
lnrpc follows the lnd versioning, thus it is recommended to specify the exact version you need for your lnd node as dependency (see [#Versioning](#Versioning)).

2
lnrpc.gemspec

@ -30,5 +30,5 @@ Gem::Specification.new do |spec|
spec.add_development_dependency "rspec", "~> 3.0"
spec.add_dependency "grpc", ">= 1.28.0"
spec.add_dependency "google-protobuf", ">=3.12"
spec.add_dependency "google-protobuf", ">=3.15.7"
end

Loading…
Cancel
Save